xfs
[Top] [All Lists]

Re: troubles with xfs

To: Steve Lord <lord@xxxxxxx>, "linux-xfs@xxxxxxxxxxx" <linux-xfs@xxxxxxxxxxx>
Subject: Re: troubles with xfs
From: kris buggenhout <gast6@xxxxxx>
Date: Tue, 23 Jan 2001 09:07:13 +0100
References: <200101221634.f0MGYc111617@xxxxxxxxxxxxxxxxxxxx>
Sender: owner-linux-xfs@xxxxxxxxxxx
Steve Lord wrote:

> gast6@xxxxxx said:
> >> ... hmmm seemed to be optimistic...
> >> I tried to repair the root with xfs repair ... that worked ... but the
> >> second time ... it moved some things to lost+found now I get an
> >> unbootable system...
> >>
> >> it boots up until    "turning on user and group quotas for local
> >> filesystems " then I get     "/etc/rc.sysinit: rm:command not found"
> >>
> >> I have to reinstall ...                 :(
> >>
> >> this is on a laptop with XFS beta4 iso (Pre Release it says on the CD)
> >>
>
> Can you give a more complete description of what you did? You say you
> tried to repair the root, was this from the miniroot?
>
> Also, as a rule, xfs_repair -n on a running filesystem can give confusing
> and invalid results. Repair is reading data direct from the disk and will
> not see anything still in buffers within the kernel, this can result in
> erroneous reports of corruption. Also running repair on a filesystem which
> was not cleanly shutdown and has not been remounted since then can also
> produce worse results than remounting the filesystem to replay the log,
> then unmounting and running repair.
>
> Finally, repair puts unlinked files in a lost+found directory, but if files
> are left there and repair is run again, it will unlink lost+found and find
> the files as unlinked again. The thing to do is to move the recovered files
> somewhere else before running repair again.
>
> Steve

I managed to do a xfs_repair on it  with the install cd ...

and had a running system again.

Only other problem I noticed = the pcmicia package = faulty ... I cant get my
network card to work ... will look into that ...
(the stock pcmcia , coming with RH7 aint good also ... it has flaws ... like
in  unstable under high load ...

So I managed to rectify the situation and could reboot.

I checked the moved file's (in lost+found) and they were both device files ...

so I think there's something with devfs ....


I will retest in a few

<Prev in Thread] Current Thread [Next in Thread>