xfs
[Top] [All Lists]

XFS on alpha problem

To: linux-xfs@xxxxxxxxxxx
Subject: XFS on alpha problem
From: Thomas Graichen <news-innominate.list.sgi.xfs@xxxxxxxxxxxxx>
Date: 13 Nov 2000 10:49:44 GMT
Distribution: local
Organization: innominate AG, Berlin, Germany
Reply-to: Thomas Graichen <graichen@xxxxxxxxxxxxx>
Reply-to: thomas.graichen@xxxxxxxxxxxxx
Sender: owner-linux-xfs@xxxxxxxxxxx
User-agent: tin/1.4.2-20000205 ("Possession") (UNIX) (Linux/2.4.0-XFS-test10 (i586))
running XFS on the alpha results in the following:

* mkfs (with 8k blocksize for the alpha)
* xfs_repair - fs is ok
* mount
* umount (nothing done on the mounted fs)
* xfs_repair:

  root@cyan:/usr/src/xfs/cmd/xfs/stress# xfs_repair /dev/sdb3
  Phase 1 - find and verify superblock...
  Phase 2 - using internal log
          - zero log...
          - scan filesystem freespace and inode maps...
  bad magic # 0x0 for agf 0
  bad version # -1 for agf 0
  bad length 0 for agf 0, should be 28491
  flfirst -2147483648 in agf 0 too large (max = 128)
  reset bad agf for ag 0
  freeblk count 1 != flcount 1086347527 in ag 0
  bad agbno 2962266880 for btbno root, agno 0
  bad agbno 16580607 for btbcnt root, agno 0
          - found root inode chunk
  Phase 3 - for each AG...

any idea?

t

-- 
thomas.graichen@xxxxxxxxxxxxxx
technical director                                       innominate AG
clustering & security                             the linux architects
tel: +49-30-308806-13   fax: -77             http://www.innominate.com

<Prev in Thread] Current Thread [Next in Thread>
  • XFS on alpha problem, Thomas Graichen <=