xfs
[Top] [All Lists]

ADD 795642 - remount -o remount,ro doesn't leave FS consistent

To: btg@xxxxxxx
Subject: ADD 795642 - remount -o remount,ro doesn't leave FS consistent
From: pv@xxxxxxxxxxxxx (cattelan@xxxxxxxxxxxx)
Date: Tue, 29 Aug 2000 15:47:33 -0700 (PDT)
Cc: linux-xfs@xxxxxxxxxxx
Reply-to: sgi.bugs.xfs@xxxxxxxxxxxxxxxxx
Sender: owner-linux-xfs@xxxxxxxxxxx
Webexec: webpvupdate,pvincident
Webpv: gibble.americas.sgi.com
View Incident: 
http://co-op.engr.sgi.com/BugWorks/code/bwxquery.cgi?search=Search&wlong=1&view_type=Bug&wi=795642

 Status : open                         Priority : 3                         
 Assigned Engineer : btg               Submitter : dxm                      
*Modified User : cattelan             *Modified User Domain : engr          
*Description :
Remounting an XFS filesystem R/O can leave the FS in an
inconsistent state. (Playing with this for long enough can
hang mount up...)

Reproduce with QA 013 or:

#!/bin/sh

DEV=/dev/hda6
MNT=/mnt/arch0

.....


==========================
ADDITIONAL INFORMATION (ADD)
From: cattelan@engr (BugWorks)
Date: Aug 29 2000 03:47:33PM
==========================

This is partially working, rw->ro at shutdown works.

rw->ro on a running active file system will most
likely hang the system.

It is unclear this can ever be made to work correctly, 
since it is hard to determine if the active vnodes are
open for reading or for read/write.

Some additional work in the linux vfs layers may be nessesary.

<Prev in Thread] Current Thread [Next in Thread>
  • ADD 795642 - remount -o remount,ro doesn't leave FS consistent, cattelan@xxxxxxxxxxxx <=