xfs
[Top] [All Lists]

Re: XFS as Root filesystem

To: "Tan Pong Heng" <pongheng@xxxxxxxxxxxxxx>
Subject: Re: XFS as Root filesystem
From: Steve Lord <lord@xxxxxxx>
Date: Wed, 05 Apr 2000 10:49:36 -0500
Cc: "Klaus Strebel" <stb@xxxxxxxxx>, linux-xfs@xxxxxxxxxxx
In-reply-to: Message from "Tan Pong Heng" <pongheng@xxxxxxxxxxxxxx> of "Wed, 05 Apr 2000 20:29:57 +0800." <000701bf9efa$a7ebe310$a6e5a9ca@aries>
Sender: owner-linux-xfs@xxxxxxxxxxx
> I sync with the latest CVS this morning and the boot process when further.
> It definitely does not like to mount read-only. As it can not be remounted
> as read-write at the moment. This will break the boot process in big way.
> Anyway, I read tried with the root mounted read-write and it when further
> and still hang somewhere after the building of window manager session.
> (I am using Mandrake 7 as the base.) I could kill the hang process and
> continue.
> But, the system finally came into the login processes. But, the gdm could
> not
> start - and will retry forever. As such, I could not get a usable system.
> The system did try to start the X server and it did tried to change the
> video
> mode but could not complete. Are all the various inode type supported on
> XFS?
> That could be the reason. Since with XFS as root filesystem, there will be
> need
> to create all kind of inodes for devices, pipe, fifo, sockets, etc on it.
> Some of
> these may not be supported or does not work correctly....
> 
> I will investigate further when I have the time...
> 


In theory devices/fifos etc should work - but I am not surprised if we have
problems. We need to narrow down exactly what is not working. If you set
your default run level to something which does not run X (level 3 on redhat,
so I suspect mandrake is the same) and then do a startx and capture the
output in a file it might tell us something.

Thanks

   Steve






<Prev in Thread] Current Thread [Next in Thread>