[Top] [All Lists]

Re: patch: introduce simple actions

To: jamal <hadi@xxxxxxxxxx>
Subject: Re: patch: introduce simple actions
From: Thomas Graf <tgraf@xxxxxxx>
Date: Sun, 20 Mar 2005 21:18:36 +0100
Cc: "David S. Miller" <davem@xxxxxxxxxxxxx>, netdev@xxxxxxxxxxx, Patrick McHardy <kaber@xxxxxxxxx>
In-reply-to: <1111349426.1092.128.camel@xxxxxxxxxxxxxxxx>
References: <1111345551.1095.82.camel@xxxxxxxxxxxxxxxx> <20050320194408.GU3086@xxxxxxxxxxxxxx> <1111349426.1092.128.camel@xxxxxxxxxxxxxxxx>
Sender: netdev-bounce@xxxxxxxxxxx
> > > +
> > > +struct tc_defact
> > > +{
> > > + tc_gen;
> > > +};
> > 
> > tcf_defact, tc_defact, .. quite easy to get this wrong. Maybe
> > it would a good idea to rename tcf_defact to tcf_defact_parm?
> > 
> sigh. another LinuxWay(tm). Unfortunately this is all over the net/sched
> code to imply something thats user specific vs kernel specific. If
> you feel strongly about it i will change it - otherwise maybe we can
> leave it till some day some brave person will clean up the whole thing?

Yes I know and I don't feel that strong about it. I just tend to dislike
it a tiny bit, I do like the struct rta_kern style better. Let's wait for
the brave knight to appear someday.

<Prev in Thread] Current Thread [Next in Thread>