netdev
[Top] [All Lists]

Re: [2.6.11-rc4-mm1 patch] fix buggy IEEE80211_CRYPT_* selects

To: Adrian Bunk <bunk@xxxxxxxxx>
Subject: Re: [2.6.11-rc4-mm1 patch] fix buggy IEEE80211_CRYPT_* selects
From: Jeff Garzik <jgarzik@xxxxxxxxx>
Date: Wed, 02 Mar 2005 01:43:04 -0500
Cc: Andrew Morton <akpm@xxxxxxxx>, netdev@xxxxxxxxxxx, linux-kernel@xxxxxxxxxxxxxxx
In-reply-to: <20050226113123.GJ3311@stusta.de>
References: <20050223014233.6710fd73.akpm@osdl.org> <20050226113123.GJ3311@stusta.de>
Sender: netdev-bounce@xxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040922
Adrian Bunk wrote:
+ select CRYPTO
select CRYPTO_AES
---help---
Include software based cipher suites in support of IEEE 802.11i (aka TGi, WPA, WPA2, WPA-PSK, etc.) for use with CCMP enabled networks.
@@ -54,10 +55,11 @@
"ieee80211_crypt_ccmp".
config IEEE80211_CRYPT_TKIP
tristate "IEEE 802.11i TKIP encryption"
depends on IEEE80211
+ select CRYPTO
select CRYPTO_MICHAEL_MIC


'select CRYPTO_AES' should 'select CRYPTO' automatically, I would hope.

        Jeff



<Prev in Thread] Current Thread [Next in Thread>