netdev
[Top] [All Lists]

Re: linux 2.6.9: r8169: eth0: PCI error (status: 0x8404). Device disable

To: Francois Romieu <romieu@xxxxxxxxxxxxx>
Subject: Re: linux 2.6.9: r8169: eth0: PCI error (status: 0x8404). Device disabled.
From: Eamonn Hamilton <EAMONN.HAMILTON@xxxxxxxx>
Date: Thu, 21 Oct 2004 10:25:43 +0100
Cc: netdev@xxxxxxxxxxx
In-reply-to: <20041020201010.GA13023@xxxxxxxxxxxxxxxxxxxxxxxxxx>
References: <1098269117.6631.5.camel@xxxxxxxxxxxxxxxxxxxxx> <20041020121520.GA4004@xxxxxxxxxxxxxxxxxxxxxxxxxx> <1098282567.6631.10.camel@xxxxxxxxxxxxxxxxxxxxx> <20041020201010.GA13023@xxxxxxxxxxxxxxxxxxxxxxxxxx>
Sender: netdev-bounce@xxxxxxxxxxx
Hi Francois,

Many apologies for the top posting, I'm in an Outlook land and it's
given me bad habits :( ( mea culpa, mea culpa, mea maxima culpa, je
m'apologie :)

As you surmised, the card seems to work OK under moderate load, but
under havy transmit load the error occurs. It hasn't been seen under
Anyway, I now have 2.6.9 patched with the patch you sent with NAPI
enabled, 2.6.7 and 2.6.8 installed. I'm also going to install another
kernel with the code you mentioned commented out as follows, yes ?

if (unlikely(status & SYSErr)) {
   /* rtl8169_pcierr_interrupt(dev); */
   break;

You also mentioned being able to enable TX checksum and segmentation
offload - how do I enable this, is it through ethtool or something more
esoteric?

Thanks again for the help, hopefully I'll be able to get this lot tested
over the next couple of days and let you know how it went.

Cheers,
Eamonn



<Prev in Thread] Current Thread [Next in Thread>