netdev
[Top] [All Lists]

Re: [patch 1/8] irda/act200l-sir: replace schedule_timeout() with msle

To: netdev@xxxxxxxxxxx, jgarzik@xxxxxxxxx, kj <kernel-janitors@xxxxxxxx>
Subject: Re: [patch 1/8] irda/act200l-sir: replace schedule_timeout() with msleep()
From: Jean Tourrilhes <jt@xxxxxxxxxxxxxxxxxx>
Date: Wed, 1 Sep 2004 14:48:15 -0700
Address: HP Labs, 1U-17, 1501 Page Mill road, Palo Alto, CA 94304, USA.
E-mail: jt@xxxxxxxxxx
In-reply-to: <20040901214003.GC7467@xxxxxxx>
Organisation: HP Labs Palo Alto
References: <E1C2cIF-0007yy-Lb@sputnik> <20040901210929.GA11442@xxxxxxxxxxxxxxxxxx> <20040901214003.GC7467@xxxxxxx>
Reply-to: jt@xxxxxxxxxx
Sender: netdev-bounce@xxxxxxxxxxx
User-agent: Mutt/1.3.28i
On Wed, Sep 01, 2004 at 11:40:03PM +0200, maximilian attems wrote:
> On Wed, 01 Sep 2004, Jean Tourrilhes wrote:
> 
> > On Wed, Sep 01, 2004 at 11:05:23PM +0200, janitor@xxxxxxxxxxxxxx wrote:
> > > I would appreciate any comments from the janitor@sternweltens list. 
> uups mangled some text there sorry for this silly email.
> > 
> >     I already commented that I don't like the confusing msleep()
> > API and I prefer the more explicit schedule_timeout().
> >     But that's only me...
> > 
> >     Jean
> 
> hmm we have still archs were HZ < 100.
> i find msleep use msecs units a lot more readable than
>       schedule_timeout((HZ + 99) / 100);
> 
> the schedule_timeout(HZ/100) gets safely converted with msleep.

        I don't have complain about converting the (HZ + 99) / 100
expressions to something saner. My beef is the fact that msleep hide
the fact that a schedule might happen. This is important in the IrDA
code.

> maks

        Jean

<Prev in Thread] Current Thread [Next in Thread>