[Top] [All Lists]

Re: [patch 1/8] irda/act200l-sir: replace schedule_timeout() with msle

To: jt@xxxxxxxxxx
Subject: Re: [patch 1/8] irda/act200l-sir: replace schedule_timeout() with msleep()
From: maximilian attems <janitor@xxxxxxxxxxxxxx>
Date: Wed, 1 Sep 2004 23:40:03 +0200
Cc: netdev@xxxxxxxxxxx, jgarzik@xxxxxxxxx, kj <kernel-janitors@xxxxxxxx>
In-reply-to: <20040901210929.GA11442@xxxxxxxxxxxxxxxxxx>
Mail-followup-to: jt@xxxxxxxxxx, netdev@xxxxxxxxxxx, jgarzik@xxxxxxxxx, kj <kernel-janitors@xxxxxxxx>
References: <E1C2cIF-0007yy-Lb@sputnik> <20040901210929.GA11442@xxxxxxxxxxxxxxxxxx>
Sender: netdev-bounce@xxxxxxxxxxx
User-agent: Mutt/1.5.6+20040722i
On Wed, 01 Sep 2004, Jean Tourrilhes wrote:

> On Wed, Sep 01, 2004 at 11:05:23PM +0200, janitor@xxxxxxxxxxxxxx wrote:
> > I would appreciate any comments from the janitor@sternweltens list. 
uups mangled some text there sorry for this silly email.
>       I already commented that I don't like the confusing msleep()
> API and I prefer the more explicit schedule_timeout().
>       But that's only me...
>       Jean

hmm we have still archs were HZ < 100.
i find msleep use msecs units a lot more readable than
        schedule_timeout((HZ + 99) / 100);

the schedule_timeout(HZ/100) gets safely converted with msleep.

kernel janitor

<Prev in Thread] Current Thread [Next in Thread>