netdev
[Top] [All Lists]

RE: Fw: [Bugme-new] [Bug 2782] New: ksoftirqd load system, kernelha ng a

To: <P@xxxxxxxxxxxxxx>, "Andrew Morton" <akpm@xxxxxxxx>
Subject: RE: Fw: [Bugme-new] [Bug 2782] New: ksoftirqd load system, kernelha ng after a few minuts
From: "David TILLOY" <dtilloy@xxxxxxxxx>
Date: Fri, 28 May 2004 14:00:08 +0200
Cc: <netdev@xxxxxxxxxxx>
Importance: Normal
In-reply-to: <40B715F3.9010200@xxxxxxxxxxxxxx>
Sender: netdev-bounce@xxxxxxxxxxx
[...]
> > http://bugme.osdl.org/show_bug.cgi?id=2782
> >
> >            Summary: ksoftirqd load system, kernel hang after a
> few minuts
> >     Kernel Version: 2.4.20-2.4.22
> >             Status: NEW
> >           Severity: blocking
> >              Owner: other_other@xxxxxxxxxxxxxxxxxxxx
> >          Submitter: dav@xxxxxxxxx
>
> I've just seen something similar with official 2.4.20+e1000 v5.2.30.1
> on a Dual Intel Xeon CPU 2.6G+hyperthreading. Note I use IRQ affinity
> so both ksoftirqd_CPU[02] are at 100%.

I've tried to use IRQ affinnity too, but without success, with or without.
I've tried to switch hyperthreading off into bios, without more success.
I've tried to deactive ACPI into bios too, problem is the same.
>
> The following is repeatable in about a minute which is good.
> I send in around 700,000 packets per second on each of 2 interfaces,
> and let the packets continually overflow the (4096 entry) buffers.
> After about a minute I can't receive any traffic, and a couple
> of occasions the machine just rebooted, so something is getting
> corrupted. I was suspecting the e1000 driver buffer management until
> I seen this?

I've repeated this trouble with some NIC card. I've reproduced this with tg3
driver (Broadcom gigabit NIC), Dual Intel PRO/100S, tg2 driver and bcm5700
driver.

regards,
David.
--


<Prev in Thread] Current Thread [Next in Thread>