netdev
[Top] [All Lists]

r8169, 2.6.2-rc2, Sager 4780 laptop

To: netdev@xxxxxxxxxxx
Subject: r8169, 2.6.2-rc2, Sager 4780 laptop
From: bhartin@xxxxxxxxxxxxxxxx
Date: Mon, 26 Jan 2004 15:19:57 -0600 (CST)
Sender: netdev-bounce@xxxxxxxxxxx
(This was meant for author of the patches located at 
http://www.fr.zoreil.com/linux/kernel/2.6.x/2.6.2-rc1/, who states to CC 
the netdev list in regards to help with these patches.  Unfortunately, the 
author only stated to CC this list, but didn't include his own email.)

I've been looking through your patches as a source for help with my new 
laptop.  It's a Sager 4780, which uses an RTL-8169 on board.  It is an 
internal PCI version.

Under kernel 2.4.22, this NIC works perfectly.

Under 2.6.1 and 2.6.2-rc2, I have the following situation.

When I scp a file onto the laptop across the NIC, I get about 
4.5Mbyte/sec, and once it reaches about 13MByte transferred, the NIC 
ceases to function.  No oops messages, no errors.  You can't ping in or 
out of the interface any longer.

When you scp a file from the laptop to elsewhere, it transfers at about 
700kbyte/sec, and once it reaches a little over 6MByte, the entire system 
locks up, hard.

This has been done on two completely different networks with varying 
hardware, as to rule out anything related to such.

I have tried your 2.6.2-rc1 patches against 2.6.2-rc2 (they apply 
cleanly).  The driver behaves the same as before.

When I apply your 2.6.1 patches against 2.6.1, I get varying responses.  
I tried a few combinations (following your order as listed).  The most
notable effect of any of them is the r8169-init-one.patch.  When I apply
that, insmod or modprobe lock up when inserting the module.  They are
unkillable processes at that point.  I even tried applying all the patches
except that one and the ethtool patch (it won't apply cleanly without the
init-one patch applied).  When I did this, I started getting messages
about "eth0: Too much work at interrupt!"  Once this occured, I rebooted
back into a stable 2.4.22 kernel.  The NIC wasn't responding.  I even
tried booting into WinXP, but the NIC still wouldn't respond.  I was
finally forced to remove the battery from the laptop (not meant to be a
user task, as it is under a screwed-down cover).  Once this was done, it
finally cleared the NIC properly and allowed me to continue.

I attempted a similar run with the 2.6.2-rc1 patches, cutting out the last 
patch on the list one-by-one.

Attached is a tar.gz containing the outputs you request in your README, 
plus 'lspci -v' output and my .config for the kernel.  This data was 
collected from a fresh 2.6.2-rc2 bootup, using your full set of 2.6.2-rc1 
patches, manually doing a 'modprobe r8169' once booted up.  The system is 
running a P4 with HT enabled, with an SMP kernel.

I'm not at all familiar with kernel debugging, but I should be able to 
carry out any tasks needed, given some minor instructions.

Please CC replies to my email address, as I'm not part of this mailing 
list.

Thanks,

Bradley Hartin - bhartin@xxxxxxxxxxxxxxxx
Communications and Network Administrator
Straus-Frank Company

Attachment: bhartin-sager4780.tar.gz
Description: Binary data

<Prev in Thread] Current Thread [Next in Thread>