netdev
[Top] [All Lists]

[OOPS] TLAN fails on ifconfig with CONFIG_HOTPLUG=n

To: linux-kernel@xxxxxxxxxxxxxxx
Subject: [OOPS] TLAN fails on ifconfig with CONFIG_HOTPLUG=n
From: jhf@xxxxxxxxxxxxxx (Joseph Fannin)
Date: Tue, 11 Nov 2003 17:29:33 -0500
Cc: netdev@xxxxxxxxxxx
Mail-followup-to: linux-kernel@xxxxxxxxxxxxxxx, netdev@xxxxxxxxxxx
Sender: netdev-bounce@xxxxxxxxxxx
User-agent: Mutt/1.5.4i
  Hello,

    I'm getting an Oops when ifup'ing a Compaq Netelligent card that
uses the tlan driver running 2.6.  The oops causes the ifconfig and
modprobe (invoked by kmod) processes to hang and the network doesn't
come up.

    The oops only happens when CONFIG_HOTPLUG=n.  I've seen the
problem in -test8, test9, and test9-bk11.  This is a Compaq Proliant
5000 with quad PPro processors.  The box has EISA slots so I have
CONFIG_EISA=y but all three NICs are pci Netelligents.  
 
   I had thought this was a problem that started in -test9, not
realizing I had turned hotplug support off when updating from -test8.
This might not be that big deal now that the problem is known -- would
it be useful to file this in the kernel Bugzilla to keep track of it?
It looks like tlan.c hasn't been touched in a long time.

I'm subscribed to linux-kernel, but not netdev.  Thanks for any help.

The Oops, dmesg, .config, and lspci -v are attached as plain text:

-- 
Joseph Fannin
jhf@xxxxxxxxxxxxxx

"Linus, please apply.  Breaks everything.  But is cool." -- Rusty Russell.

Attachment: oops.txt
Description: Text document

Attachment: config-2.6.0-test9.txt
Description: Text document

Attachment: lspci-v.txt
Description: Text document

Attachment: dmesg.txt
Description: Text document

Attachment: signature.asc
Description: Digital signature

<Prev in Thread] Current Thread [Next in Thread>