devfs
[Top] [All Lists]

Re: devfs/cdrom problem

To: Gary Shea <shea@xxxxxxxxxxxxx>
Subject: Re: devfs/cdrom problem
From: Richard Gooch <rgooch@xxxxxxxxxxxxxxx>
Date: Thu, 29 Nov 2001 15:32:00 -0700
Cc: devfs@xxxxxxxxxxx
In-reply-to: <Pine.LNX.4.40.0111291132480.3566-100000@xxxxxxxxxxxx>
References: <200111291759.fATHxUf31906@xxxxxxxxxxxxxxxxxxxxxxxx> <Pine.LNX.4.40.0111291132480.3566-100000@xxxxxxxxxxxx>
Sender: owner-devfs@xxxxxxxxxxx
Gary Shea writes:
> Richard Gooch (rgooch@xxxxxxxxxxxxxxx) wrote:
> > Gary Shea writes:
> > > I just installed Mandrake 8.1 (which comes with 2.4.8) on a P3 box, and
> > > am having trouble getting my ATAPI cdrom drive working with devfs.  I'd
> > > never heard of devfs before -- elegant idea.
> > >
> > > The symptom is that the cd player doesn't work.  Digging around, I
> > > found that there is a /dev/cdrom link to /dev/cdroms/cdrom0, but the
> > > latter has major number 11, so it's a SCSI cdrom device.  It should
> > > be 22 of course, hdc.  At least that's what I'd expect!
> >
> > Why should it be 22? You should be able to use an ATAPI CD-ROM via the
> > sr_mod and ide-scsi drivers, which would give you major 11 devices.
> >
> [...]
> >
> > I don't think this is a devfs problem. You may have a device that
> > doesn't work properly with ide-scsi.
> 
> Ok, that makes sense.  I've never used ide-scsi.
> 
> I've now tried this with two different atapi cdroms, one of which is a
> brand new burner, the other a cd/dvd drive, and neither are bottom of
> the barrel junk.  In both cases the drives get mapped to (11,0), and
> cannot be mounted/played.  I haven't tried a vanilla cdrom yet.
> 
> I wouldn't be surprised if this has to do with Mandrake's distribution as
> a few others are reporting the same problem, but unless I want to
> rebuild the machine (again...), I have to live with it.
> 
> Is it possible for me to convince devfs to assign the cdrom to (the devfs
> equivalent of) /dev/hdc, at least until Mandrake 8.2?  I don't really
> understand why the ide cdroms should be run through the scsi driver
> anyway, and since they don't work there, I'd just as soon avoid it.
> The ide drivers are in the kernel, not modules, and I've already tried
> append " hdc=cdrom"
> in lilo to no avail.

Did you take out the "hdc=ide-scsi" boot line?

Something (not devfs) is causing your ATAPI CD-ROM to be managed by
the ide-scsi driver, rather than the ide-cd driver.

                                Regards,

                                        Richard....
Permanent: rgooch@xxxxxxxxxxxxx
Current:   rgooch@xxxxxxxxxxxxxxx

<Prev in Thread] Current Thread [Next in Thread>